Skip to main content
CVE-2024-38440VulnerabilityPublished Updated

Netatalk 3.2.0 has an off-by-one error and resultant heap-based buffer overflow because of incorrectly using FPLoginExt in BN_bin2bn in etc/uams/uams_dhx_pam.c

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-38440· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 3.2.1 soon.

Data as of 29 Oct 2026, 22:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade netatalk/netatalk to 3.2.1.

Affected software

ProductAffectedFixed in
GitHubnetatalk/netatalkpkg:github/netatalk/netatalkOther threatsAffected
  • <3.2.1
Fixed in
  • 3.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Netatalk 3.2.0 has an off-by-one error and resultant heap-based buffer overflow because of incorrectly using FPLoginExt in BN_bin2bn in etc/uams/uams_dhx_pam.c.

References

Community reviews

Loading reviews…