Skip to main content
CVE-2026-120431VulnerabilityPublished

Netpbm before 10.86.51, 11.x before 11.02.29, and 11.03 before 11.15.07 contains a heap-based buffer overflow in

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-120431· High 8.5

Not known to be exploited · CVSS 8.5 High · fixed in 11.15.07 : patch Netpbm soon.

Data as of 2 Nov 2026, 16:58 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.5
CNA (VulnCheck)CVSS 3.17.8
Patch
Available – fixed in 11.15.07, 11.02.29, 10.86.51
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Netpbm to 11.15.07, 11.02.29 or 10.86.51.

Affected software

ProductAffectedFixed in
NetpbmNetpbmAffected
  • >=11.03 <11.15.07
Fixed in
  • 11.15.07
NetpbmNetpbmAffected
  • >=11.0 <11.02.29
Fixed in
  • 11.02.29
NetpbmNetpbmAffected
  • <10.86.51
Fixed in
  • 10.86.51

AI-suggested

The vulnerability affects Netpbm versions before 10.86.51, 11.x before 11.02.29, and 11.03 before 11.15.07. Users should upgrade to versions 10.86.51 or later, 11.02.29 or later for 11.x, and 11.15.07 or later for 11.03 to mitigate this issue. Patch status is not explicitly confirmed in the input, but the version boundaries indicate fixes exist in those later versions. No additional mitigation guidance is provided.

Description

A heap-based buffer overflow vulnerability exists in Netpbm's sgitopnm readChannels() function when processing RLE-compressed SGI images. This affects versions before 10.86.51, all 11.x versions before 11.02.29, and 11.03 versions before 11.15.07. Crafted SGI files with oversized offset table lengths can cause memory corruption, leading to crashes or potential code execution.

References

Community reviews

Loading reviews…