Skip to main content
CVE-2026-116539VulnerabilityPublished Updated

SUSE · netty-tcnative-2.0.85-1.1 on GA media

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-116539· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade SUSE io.netty:netty-tcnative to 2.0.84.Final soon.

Data as of 5 Nov 2026, 00:56 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.2
CNA (VulnCheck)CVSS 3.15.9
Patch
Available – fixed in 2.0.84.Final
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade netty-tcnative and netty-tcnative-boringssl-static and io.netty/netty-tcnative and io.netty/netty-tcnative-boringssl-static to 2.0.84.Final.

Affected software

ProductAffectedFixed in
netty-tcnativeio.netty:netty-tcnativeAffected
  • <2.0.84.Final
Fixed in
  • 2.0.84.Final
netty-tcnative-boringssl-staticio.netty:netty-tcnative-boringssl-staticAffected
  • <2.0.84.Final
Fixed in
  • 2.0.84.Final
Mavenio.netty/netty-tcnativepkg:maven/io.netty/netty-tcnativeOther threatsAffected
  • <2.0.84.Final
Fixed in
  • 2.0.84.Final
Mavenio.netty/netty-tcnative-boringssl-staticpkg:maven/io.netty/netty-tcnative-boringssl-staticOther threatsAffected
  • <2.0.84.Final
Fixed in
  • 2.0.84.Final

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version of the netty-tcnative package (2.0.85-1.1) is available on the GA media of openSUSE Tumbleweed. Users should update to this version to apply the security fixes. No additional mitigation guidance is provided.

Description

Multiple security issues were addressed in the netty-tcnative-2.0.85-1.1 package distributed with openSUSE Tumbleweed GA media. The details pertain to fixes applied by the SUSE Product Security Team. No specific vulnerabilities or impacts are described in the available data.

References

Community reviews

Loading reviews…