Network-AI from 5.13.4 before 5.15.5 contains a path traversal vulnerability in FileJobStore that allows attackers to
Source GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 5.15.5 soon.
Data as of 2 Nov 2026, 04:43 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 8.8 |
- Patch
- Available – fixed in 5.15.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade Network-AI to 5.15.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JovancodingNetwork-AI | Affected
| Fixed in
|
npmNetwork-AIpkg:npm/Network-AIOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict access to interfaces that accept job id inputs and monitor for suspicious activity involving file access or deletion.
Description
Network-AI versions from 5.13.4 up to but not including 5.15.5 contain a path traversal vulnerability in the FileJobStore component. This flaw allows attackers who can control the job id parameter to read or delete arbitrary .json files by using directory traversal sequences. Exploitation can lead to disclosure of sensitive credentials and grant tokens or deletion of configuration files, potentially weakening the authorization mechanism of AuthGuardian.