Skip to main content
CVE-2024-31079VulnerabilityPublished Updated

CVE-2024-31079: NGINX HTTP/3 QUIC vulnerability

Affects nginxSource GCVE Database

0

Not known to be exploited : upgrade to 1.26.1 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.8% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.26.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade nginx to 1.26.1.

Affected software

ProductAffectedFixed in
Bitnaminginxpkg:bitnami/nginxOther threatsAffected
  • >=1.25.0 <1.26.1
Fixed in
  • 1.26.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade NGINX to version 1.26.1 or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2024-31079 is a medium severity vulnerability affecting NGINX Plus and NGINX OSS when configured with the HTTP/3 QUIC module. Specifically crafted HTTP/3 requests, timed during the connection draining process, can cause NGINX worker processes to terminate or lead to other potential impacts. Exploitation requires precise timing that attackers have limited control or visibility over. A patch is available for affected versions.

References

Community reviews

Loading reviews…