CVE-2024-32760: NGINX HTTP/3 QUIC vulnerability
Affects nginxSource GCVE Database
Not known to be exploited : upgrade to 1.26.1 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.26.1
Exploitation evidence
Disclosed: evidence found.
CVE published 4 Jun 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade nginx to 1.26.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnaminginxpkg:bitnami/nginxOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade NGINX to version 1.26.1 or later to remediate the issue. No additional mitigation steps are specified.
Description
CVE-2024-32760 is a medium severity vulnerability affecting NGINX Plus and NGINX OSS when configured with the HTTP/3 QUIC module. Certain undisclosed HTTP/3 encoder instructions can cause NGINX worker processes to terminate or lead to other potential impacts. The issue affects NGINX versions from 1.25.0 up to but not including 1.26.1. A patch is available to address this vulnerability.
References
- my.f5.com/manage/s/article/K000139609 (opens in a new tab)
- openwall.com/lists/oss-security/2024/05/30/4 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MLAOKJWDALQZBIV3WKGPJ6T5Z56D3PRD/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/R7RPLWC35WHEUFCGKNFG62ESNID25TEZ/ (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-32760 (opens in a new tab)