Skip to main content
CVE-2026-95101VulnerabilityPublished Updated

Microsoft · NGINX ngx_http_v3_module vulnerability

Affects MicrosoftSource GCVE Database

0
Compare
Authoritative record:CVE-2026-95101· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in 37.2.0.1 : update Microsoft when convenient.

Data as of 2 Nov 2026, 10:58 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 37.2.0.1, 37.0.7.1, 1.31.7 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade NGINX Plus to 37.2.0.1 or 37.0.7.1; NGINX Open Source to 1.31.7 or 1.30.6; f5/nginx-plus to 37.2.0.1, 37.0.7.1, 1.31.7 or 1.30.6.

Affected software

ProductAffectedFixed in
F5NGINX PlusAffected
  • >=37.1.0 <37.2.0.1
  • >=37.0.0 <37.0.7.1
  • >=R36
  • >=R35
  • >=R34
  • >=R33
Fixed in
  • 37.2.0.1
  • 37.0.7.1
F5NGINX Open SourceAffected
  • >=1.31.0 <1.31.7
  • >=1.30.0 <1.30.6
  • >=1.25.0
Fixed in
  • 1.31.7
  • 1.30.6
F5f5/nginx-pluspkg:rpm/f5/nginx-plusOther threatsAffected
  • >=37.1.0 <37.2.0.1
  • >=37.0.0 <37.0.7.1
  • >=36
  • >=35
  • >=34
  • >=33
  • >=1.31.0 <1.31.7
  • >=1.30.0 <1.30.6
  • >=1.25.0
Fixed in
  • 37.2.0.1
  • 37.0.7.1
  • 1.31.7
  • 1.30.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

CVE-2026-95101 is a published vulnerability affecting version 3.0 of the NGINX ngx_http_v3_module. The vulnerability is cataloged under CWE-172. There is no evidence of exploitation in the wild.

References

Community reviews

Loading reviews…