Skip to main content
VulnerabilityPublished Updated

CVE-2026-97205: NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_core_module module

Affects nginxSource GCVE Database

0
Authoritative record:CVE-2026-97205· High 8.1

Not known to be exploited · CVSS 8.1 High · fixed in 1.18.0-6ubuntu14.22 : patch nginx soon.

Data as of 26 Oct 2026, 23:28 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.18.0-6ubuntu14.22, 1.24.0-2ubuntu7.19, 1.30.4-7ubuntu1.1 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10nginxpkg:deb/ubuntu/nginx?arch=source&distro=stonkingOther threatsAffected
  • <1.30.4-7ubuntu1.1
Fixed in
  • 1.30.4-7ubuntu1.1
Ubuntu 26.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=resoluteOther threatsAffected
  • <1.28.3-2ubuntu1.12
Fixed in
  • 1.28.3-2ubuntu1.12
Ubuntu 24.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=nobleOther threatsAffected
  • <1.24.0-2ubuntu7.19
Fixed in
  • 1.24.0-2ubuntu7.19
Ubuntu 22.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=jammyOther threatsAffected
  • <1.18.0-6ubuntu14.22
Fixed in
  • 1.18.0-6ubuntu14.22
Ubuntu Pro 20.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra/focalOther threatsAffected
  • 1.16.1-0ubuntu2 – 1.18.0-0ubuntu1.7+esm3
21 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1.12.1-0ubuntu2 – 1.14.0-0ubuntu1.11+esm4
19 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_core_module module. When asynchronous file I/O (AIO) is enabled in certain configurations, processing a Server Side Includes (SSI) page containing “include virtual” commands may trigger a Use-After-Free (UAF) in the NGINX worker process. This may cause memory corruption or a worker process crash. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Impact: This vulnerability may allow remote attackers to cause a denial-of-service (DoS) on the NGINX system, corrupt its memory, or possibly trigger code execution. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…