Skip to main content
VulnerabilityPublished Updated

CVE-2026-60005: NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_slice_module module

Affects nginxSource GCVE Database

0
Authoritative record:CVE-2026-60005· High 8.2

Not known to be exploited · CVSS 8.2 High · fixed in 1.18.0-6ubuntu14.17 : patch nginx soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.18.0-6ubuntu14.17, 1.24.0-2ubuntu7.14, 1.28.3-2ubuntu1.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu nginx to 1.18.0-6ubuntu14.17 (package) or 1.24.0-2ubuntu7.14 (package) or 1.28.3-2ubuntu1.7 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=resoluteOther threatsAffected
  • <1.28.3-2ubuntu1.7
Fixed in
  • 1.28.3-2ubuntu1.7
Ubuntu 24.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=nobleOther threatsAffected
  • <1.24.0-2ubuntu7.14
Fixed in
  • 1.24.0-2ubuntu7.14
Ubuntu 22.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=jammyOther threatsAffected
  • <1.18.0-6ubuntu14.17
Fixed in
  • 1.18.0-6ubuntu14.17
Ubuntu Pro 20.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra/focalOther threatsAffected
  • 1.16.1-0ubuntu2 – 1.18.0-0ubuntu1.7+esm3
21 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1.12.1-0ubuntu2 – 1.14.0-0ubuntu1.11+esm4
19 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSnginxpkg:deb/ubuntu/nginx?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • 1.9.3-1ubuntu1 – 1.10.3-0ubuntu0.16.04.5+esm9
30 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_slice_module module. When the slice directive and unnamed regex captures are configured or when a background cache update happens, unauthenticated attackers can send requests that may cause uninitialized memory access in the NGINX worker process, leading to limited disclosure of memory or a restart. Impact: This vulnerability may allow remote, unauthenticated attackers to have limited control to disclose memory contents or restart the NGINX worker process. There is no control plane exposure; this is a data plane issue only. Note: The ngx_http_slice_module module is not enabled by default; it's enabled with the --with-http_slice_module configuration parameter. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…