Skip to main content
VulnerabilityPublished Updated

CVE-2026-84313: Nginx UI · TOTP / passkey enrolment requires no re-authentication, enabling persistent account takeover

Affects github.com/0xJacky/Nginx-UISource GCVE Database

0
Authoritative record:CVE-2026-84313· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 1.9.10-0.20260703131214-23d1934099b0 soon.

Data as of 28 Oct 2026, 17:11 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.10-0.20260703131214-23d1934099b0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade github.com/0xJacky/Nginx-UI to 1.9.10-0.20260703131214-23d1934099b0.

Affected software

ProductAffectedFixed in
Gogithub.com/0xJacky/Nginx-UIAffected
  • <1.9.10-0.20260703131214-23d1934099b0
Fixed in
  • 1.9.10-0.20260703131214-23d1934099b0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in version 1.9.10-0.20260703131214-23d1934099b0 that moves the TOTP and passkey enrollment routes inside the RequireSecureSession middleware group. Additionally, it is recommended to require the user's current password in the enrollment requests to prevent unauthorized second factor binding. Operators should monitor the users and passkeys tables for unexpected OTPSecret or passkey entries as no reliable workaround exists.

Description

Nginx UI contains a vulnerability (CVE-2026-84313) where endpoints for enrolling TOTP and WebAuthn passkeys do not require re-authentication beyond a valid JWT. This allows an attacker with a stolen JWT to bind their own second factor to a victim's account without needing the victim's password, enabling persistent account takeover even after password resets. The issue arises because these enrollment routes are registered outside the secure session middleware, and there is insufficient verification to prevent multiple or unauthorized enrollments. A patch is available that moves these routes inside the secure session group and recommends requiring the current password for such sensitive actions.

References

Community reviews

Loading reviews…