Skip to main content
CVE-2026-121736VulnerabilityPublished

NocoDB 0.300.0 before 2026.08.0 contains a missing authentication vulnerability in the POST /api/v2/oauth/authorize

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-121736· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 2026.08.0 when convenient.

Data as of 4 Nov 2026, 02:00 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.15.3
Patch
Available – fixed in 2026.08.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade nocodb to 2026.08.0.

Affected software

ProductAffectedFixed in
nocodbnocodbAffected
  • >=0.300.0 <2026.08.0
Fixed in
  • 2026.08.0
npmnocodbpkg:npm/nocodbOther threatsAffected
  • >=0.300.0 <2026.08.0
Fixed in
  • 2026.08.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in NocoDB version 2026.08.0 and later. Users should upgrade to version 2026.08.0 or newer to remediate this vulnerability. No additional mitigation steps are indicated in the available data.

Description

NocoDB versions 0.300.0 up to but not including 2026.08.0 have a missing authentication vulnerability in the POST /api/v2/oauth/authorize endpoint. This flaw allows unauthenticated attackers to create OAuth authorization codes by sending requests with specific parameters, resulting in unbounded insertion of ownerless authorization code records. The vulnerability is limited by rate limiting but can lead to unauthorized creation of authorization codes.

References

Community reviews

Loading reviews…