Node axios: Versions prior to 1.15.0 and 0.3.1 are vulnerable to a specific gadget-style attack chain in which
Affects node-axiosSource GCVE Database
Not known to be exploited · CVSS 8.1 High · fixed in 0.19.0+dfsg-2ubuntu0.1~esm1 : patch node-axios soon.
Data as of 6 Nov 2026, 23:24 UTC
- EPSS
- 1.9% chance of exploitation in 30 days – higher than 80% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.19.0+dfsg-2ubuntu0.1~esm1, 0.26.0+dfsg-1ubuntu0.1~esm1, 1.6.8+dfsg-2ubuntu0.1~esm1 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 26.04 LTSnode-axiospkg:deb/ubuntu/node-axios?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10node-axiospkg:deb/ubuntu/node-axios?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSnode-axiospkg:deb/ubuntu/node-axios?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSnode-axiospkg:deb/ubuntu/node-axios?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSnode-axiospkg:deb/ubuntu/node-axios?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and should be applied by updating Axios to version 1.15.0 or later (or 0.3.1 or later for the older branch). Ubuntu users should apply the security updates provided in the Ubuntu Security Notice USN-8638-1 for their respective LTS releases. Standard system updates will apply the necessary patches. No additional mitigation steps are indicated beyond applying these updates.
Description
Axios versions prior to 1.15.0 and 0.3.1 contain a vulnerability where prototype pollution in a third-party dependency can be exploited to inject unsanitized HTTP header values into outbound requests. This can lead to HTTP header injection. The issue is fixed in versions 1.15.0 and 0.3.1. The vulnerability has a high severity with a CVSS score of 8.1. Ubuntu has issued security notices with patches available for various LTS releases.
References
- ubuntu.com/security/CVE-2026-40175 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-40175 (opens in a new tab)
- github.com/axios/axios/security/advisories/GHSA-fvcv-3m26-pcqx (opens in a new tab)
- github.com/axios/axios/pull/10660 (opens in a new tab)
- github.com/axios/axios/commit/363185461b90b1b78845dc8a99a1f103d9b122a1 (opens in a new tab)
- github.com/axios/axios/releases/tag/v1.15.0 (opens in a new tab)
- ubuntu.com/security/notices/USN-8638-1 (opens in a new tab)