CVE-2026-59868: Node js yaml · js-yaml is a JavaScript YAML parser and dumper
Affects node-js-yamlSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium · fixed in 5.2.0 : update node-js-yaml when convenient.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10node-js-yamlpkg:deb/ubuntu/node-js-yaml?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSnode-js-yamlpkg:deb/ubuntu/node-js-yaml?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10node-js-yamlpkg:deb/ubuntu/node-js-yaml?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSnode-js-yamlpkg:deb/ubuntu/node-js-yaml?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSnode-js-yamlpkg:deb/ubuntu/node-js-yaml?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSnode-js-yamlpkg:deb/ubuntu/node-js-yaml?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade js-yaml to version 5.2.0 or later to remediate this vulnerability. For affected Ubuntu packages, update to versions beyond 3.13.1+dfsg-2 or the equivalent patched releases. No other mitigations are specified.
Description
CVE-2026-59868 is a vulnerability in js-yaml versions from 5.0.0 up to but not including 5.2.0 that allows excessive CPU consumption via chained merge keys in YAML documents. This leads to quadratic CPU time growth, potentially causing a denial of service. The issue is fixed in version 5.2.0. Specific affected Ubuntu package versions include 3.9.1+dfsg-1, 3.10.0+dfsg-1, and 3.13.1+dfsg-2.
References
- ubuntu.com/security/CVE-2026-59868 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-59868 (opens in a new tab)
- github.com/nodeca/js-yaml/security/advisories/GHSA-g796-fgmg-93mv (opens in a new tab)
- github.com/nodeca/js-yaml/commit/3105455b81dee69e0fd36e09ac0b2ccfdb54adc1 (opens in a new tab)
- github.com/nodeca/js-yaml/releases/tag/5.2.0 (opens in a new tab)