Skip to main content
VulnerabilityPublished Updated

CVE-2025-13465: Node lodash · Lodash versions 4.0.0 through 4.17.22 are vulnerable to prototype pollution in the

Affects node-lodashSource GCVE Database

0

Not known to be exploited · CVSS 8.2 High · fixed in 2.4.1+dfsg-3ubuntu0.1~esm1 : patch node-lodash soon.

Data as of 27 Oct 2026, 06:42 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.1+dfsg-3ubuntu0.1~esm1, 4.17.4+dfsg-1ubuntu0.1~esm1, 4.17.15+dfsg-2ubuntu0.1~esm1 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10node-lodashpkg:deb/ubuntu/node-lodash?arch=source&distro=questingOther threatsAffected
  • <4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.25.10.1
Fixed in
  • 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.25.10.1
Ubuntu Pro 24.04 LTSnode-lodashpkg:deb/ubuntu/node-lodash?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.24.04.1~esm1
Fixed in
  • 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.24.04.1~esm1
Ubuntu Pro 22.04 LTSnode-lodashpkg:deb/ubuntu/node-lodash?arch=source&distro=esm-apps/jammyOther threatsAffected
  • <4.17.21+dfsg+~cs8.31.198.20210220-5ubuntu0.1~esm1
Fixed in
  • 4.17.21+dfsg+~cs8.31.198.20210220-5ubuntu0.1~esm1
Ubuntu Pro 20.04 LTSnode-lodashpkg:deb/ubuntu/node-lodash?arch=source&distro=esm-apps/focalOther threatsAffected
  • <4.17.15+dfsg-2ubuntu0.1~esm1
Fixed in
  • 4.17.15+dfsg-2ubuntu0.1~esm1
Ubuntu Pro 18.04 LTSnode-lodashpkg:deb/ubuntu/node-lodash?arch=source&distro=esm-apps/bionicOther threatsAffected
  • <4.17.4+dfsg-1ubuntu0.1~esm1
Fixed in
  • 4.17.4+dfsg-1ubuntu0.1~esm1
Ubuntu Pro 16.04 LTSnode-lodashpkg:deb/ubuntu/node-lodash?arch=source&distro=esm-apps-legacy/xenialOther threatsAffected
  • <2.4.1+dfsg-3ubuntu0.1~esm1
Fixed in
  • 2.4.1+dfsg-3ubuntu0.1~esm1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Lodash versions 4.0.0 through 4.17.22 are vulnerable to prototype pollution in the _.unset and _.omit functions. An attacker can pass crafted paths which cause Lodash to delete methods from global prototypes. The issue permits deletion of properties but does not allow overwriting their original behavior. This issue is patched on 4.17.23

References

Community reviews

Loading reviews…