CVE-2026-111759: Node markdown it · (markdown-it is a Markdown parser
Affects node-markdown-itSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 14.3.2 : patch node-markdown-it soon.
Data as of 27 Oct 2026, 07:59 UTC
- Patch
- Available – fixed in 14.3.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 19 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CISA SSVC: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by GitHub, Inc.
, 3 days before disclosure
CVE published
on cve.org
, t = 0
CISA SSVC assessment
proof of concept public
, 43 minutes after disclosure
In Threat Radar
record ingested
, 7 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10node-markdown-itpkg:deb/ubuntu/node-markdown-it?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSnode-markdown-itpkg:deb/ubuntu/node-markdown-it?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSnode-markdown-itpkg:deb/ubuntu/node-markdown-it?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSnode-markdown-itpkg:deb/ubuntu/node-markdown-it?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade markdown-it to version 14.3.2 or later, or 15.0.2 or later, where the vulnerability is fixed.
Description
Node markdown-it versions 10.0.0+dfsg-2 through 10.0.0+dfsg-6 contain a vulnerability identified as CVE-2026-111759. This vulnerability has a CVSS 3.1 score of 7.5 (high severity) and impacts availability without affecting confidentiality or integrity. The vulnerability is present prior to versions 14.3.2 and 15.0.2.