Skip to main content
CVE-2026-119189VulnerabilityPublished Updated

Node node forge: Prior to 1.4.1, node-forge enforced an X.509 CA certificate's basicConstraints.pathLenConstraint only

Affects node-node-forgeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-119189· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium · fixed in 1.4.1 : update node-node-forge when convenient.

Data as of 5 Nov 2026, 12:35 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.15.9
Patch
Available – fixed in 1.4.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 22.04 LTSnode-node-forgepkg:deb/ubuntu/node-node-forge?arch=source&distro=jammyOther threatsAffected
  • =0.10.0~dfsg-3
  • =1.2.1~dfsg-2
Fixed in–
Ubuntu 20.04 LTSnode-node-forgepkg:deb/ubuntu/node-node-forge?arch=source&distro=focalOther threatsAffected
  • =0.8.5~dfsg-2
  • =0.9.1~dfsg-1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Forge (also called node-forge) is a native implementation of Transport Layer Security in JavaScript. Prior to 1.4.1, node-forge enforced an X.509 CA certificate's basicConstraints.pathLenConstraint only when that certificate also carried a keyUsage extension. Exploitation requires a path-length-constrained CA without keyUsage that chains to a root trusted by the application, and an attacker who holds that CA's private key or obtains a subordinate CA certificate from it. The attacker could then construct a chain exceeding the declared path length that still passed pki.verifyCertificateChain(). Public web PKI CA certificates normally include keyUsage; private PKIs with CA certificates created without it are more likely to be affected. This issue is fixed in version 1.4.1.

References

Community reviews

Loading reviews…