Skip to main content
CVE-2026-59874VulnerabilityPublished Updated

Node tar: Prior to 7.5.18, tar.replace accepts a checksum-valid tar header with a negative base-256 encoded entry

Affects node-tarSource GCVE Database

0
Authoritative record:CVE-2026-59874· High 8.7

Not known to be exploited · CVSS 8.7 High · fixed in 7.5.18 : patch node-tar soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.5.18
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10node-tarpkg:deb/ubuntu/node-tar?arch=source&distro=stonkingOther threatsAffected
  • =6.2.1+ds1+~cs6.1.13-10
  • =7.5.22+~4.0.1-1
Fixed in–
Ubuntu 26.04 LTSnode-tarpkg:deb/ubuntu/node-tar?arch=source&distro=resoluteOther threatsAffected
  • 6.2.1+~cs7.0.8-1 – 6.2.1+ds1+~cs6.1.13-10
4 affected builds
Fixed in–
Ubuntu 25.10node-tarpkg:deb/ubuntu/node-tar?arch=source&distro=questingOther threatsAffected
  • =6.2.1+~cs7.0.8-1
Fixed in–
Ubuntu 24.04 LTSnode-tarpkg:deb/ubuntu/node-tar?arch=source&distro=nobleOther threatsAffected
  • =6.1.13+~cs7.0.5-1
  • =6.1.13+~cs7.0.5-3
Fixed in–
Ubuntu 22.04 LTSnode-tarpkg:deb/ubuntu/node-tar?arch=source&distro=jammyOther threatsAffected
  • =6.1.7+~cs11.3.10-1
  • =6.1.11+~cs11.3.10-1
  • =6.1.11+ds1+~cs6.0.6-1
Fixed in–
Ubuntu Pro 20.04 LTSnode-tarpkg:deb/ubuntu/node-tar?arch=source&distro=esm-apps/focalOther threatsAffected
  • =4.4.10+ds1-2
  • =4.4.10+ds1-2ubuntu1
  • =4.4.10+ds1-2ubuntu1+esm1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade node-tar to version 7.5.18 or later where this vulnerability is fixed. No other mitigations are specified.

Description

CVE-2026-59874 is a vulnerability in the node-tar library for Node.js versions prior to 7.5.18. The tar.replace function can accept a checksum-valid tar header with a negative base-256 encoded entry size, causing the archive scanner to stall by repeatedly parsing the same header. This issue is resolved in version 7.5.18.

References

Community reviews

Loading reviews…