Skip to main content
CVE-2026-109855VulnerabilityPublished Updated

Node undici:

Affects node-undiciSource GCVE Database

0

Not known to be exploited · CVSS 7.5 High · fixed in 8.11.2 : patch node-undici soon.

Data as of 28 Oct 2026, 23:44 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 8.11.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10node-undicipkg:deb/ubuntu/node-undici?arch=source&distro=stonkingOther threatsAffected
  • 7.18.2+dfsg+~cs3.2.0-1build1 – 8.9.0+dfsg+~cs3.2.0-1
5 affected builds
Fixed in–
Ubuntu 26.04 LTSnode-undicipkg:deb/ubuntu/node-undici?arch=source&distro=resoluteOther threatsAffected
  • 7.3.0+dfsg1+~cs24.12.11-2 – 7.18.2+dfsg+~cs3.2.0-1build1
4 affected builds
Fixed in–
Ubuntu 24.04 LTSnode-undicipkg:deb/ubuntu/node-undici?arch=source&distro=nobleOther threatsAffected
  • =5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1
  • =5.26.3+dfsg1+~cs23.10.12-2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade undici to version 8.11.2 or later where the issue is fixed. As a temporary workaround, disable HTTP/2 for WebSocket connections by setting allowH2 to false, or avoid opening WebSocket connections to untrusted servers.

Description

Node.js HTTP client library undici versions 8.11.0 and 8.11.1 contain a vulnerability in the experimental WebSocket client enabled by default with HTTP/2. A failed WebSocket handshake over HTTP/2 leaves an HTTP/2 stream open without error handling, causing an unhandled error that crashes the Node.js process. This allows a remote unauthenticated server to cause a denial of service by crashing clients that open WebSocket connections over HTTP/2. The issue is fixed in version 8.11.2.

References

Community reviews

Loading reviews…