Skip to main content
CVE-2026-112085VulnerabilityPublished Updated

Node webpack:

Affects node-webpackSource GCVE Database

0
Authoritative record:CVE-2026-112085· High 8.2

Not known to be exploited · CVSS 8.2 High · fixed in 5.2.7 : patch node-webpack soon.

Data as of 28 Oct 2026, 23:13 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.2.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10node-webpackpkg:deb/ubuntu/node-webpack?arch=source&distro=stonkingOther threatsAffected
  • =5.105.4+dfsg1+~cs15.13.23-2
  • =5.108.0+dfsg1+~cs14.7.20-2
Fixed in–
Ubuntu 26.04 LTSnode-webpackpkg:deb/ubuntu/node-webpack?arch=source&distro=resoluteOther threatsAffected
  • =5.97.1+dfsg1+~cs11.18.27-3
  • =5.97.1+dfsg1+~cs11.18.27-4
  • =5.105.4+dfsg1+~cs15.13.23-2
Fixed in–
Ubuntu 24.04 LTSnode-webpackpkg:deb/ubuntu/node-webpack?arch=source&distro=nobleOther threatsAffected
  • =5.76.1+dfsg1+~cs17.16.16-1
Fixed in–
Ubuntu 22.04 LTSnode-webpackpkg:deb/ubuntu/node-webpack?arch=source&distro=jammyOther threatsAffected
  • =4.43.0-6build4
  • =4.43.0-7
Fixed in–
Ubuntu 20.04 LTSnode-webpackpkg:deb/ubuntu/node-webpack?arch=source&distro=focalOther threatsAffected
  • =4.7.0-3
  • =4.30.0-7
  • =4.30.0-9
Fixed in–
Ubuntu 18.04 LTSnode-webpackpkg:deb/ubuntu/node-webpack?arch=source&distro=bionicOther threatsAffected
  • =3.5.6-1build3
  • =3.5.6-1build4
  • =3.5.6-2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade webpack-dev-server to version 5.2.7 or later, or 6.1.0 or later, where the vulnerability is fixed by proper Host and Origin header validation on proxied WebSocket upgrades. As a temporary workaround, avoid forwarding WebSocket connections in proxy entries that do not require it and restrict proxying to specific paths to reduce exposure.

Description

In webpack-dev-server versions before 5.2.7 and version 6.0.0, a vulnerability exists in the proxy WebSocket forwarding feature. The server forwards non-HMR WebSocket upgrade requests to the proxy target without validating Host or Origin headers, bypassing allowedHosts protections. This allows a malicious web page visited by a developer to open a cross-origin WebSocket through the dev server and interact with the proxied backend, even if the server is bound to loopback. The issue is fixed in versions 5.2.7 and 6.1.0.

References

Community reviews

Loading reviews…