Skip to main content
VulnerabilityPublished

nono-py's policy JSON accepts unknown security fields

Affects nono-pySource GCVE Database

0

CVSS 5.2 Medium : upgrade to 0.10.1 when convenient.

Data as of 26 Jun 2026, 22:08 UTC

CVSS 3.1 base score
5.2Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.10.1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

What to do

Upgrade nono-py to 0.10.1.

Affected software

ProductAffectedFixed in
PyPInono-pyAffected
  • <0.10.1
Fixed in
  • 0.10.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in nono-py version 0.10.1 and later; users should upgrade to at least version 0.10.1 to address this issue. For users on older Linux kernels without Landlock ABI v4 network rules, ensure that policy-resolved proxy configurations are explicitly coupled with CapabilitySet.proxy_only enforcement, as relying solely on proxy environment variables is insufficient. Patch status is not explicitly confirmed beyond the version indication; users should verify with the vendor advisory for the latest remediation guidance.

Description

The nono-py library has a vulnerability in its policy JSON handling that can cause sandboxed processes to bypass intended network restrictions. Specifically, the policy-derived ProxyConfig does not enforce the proxy_only capability automatically, allowing direct network access outside the configured proxy allowlist. Additionally, the policy JSON accepts unknown security-sensitive fields, which can be silently ignored if misspelled or unsupported. This may lead to broader network access than intended, potentially exposing sensitive data depending on the environment. Users on older Linux kernels without Landlock ABI v4 must ensure proxy configurations are properly coupled with proxy_only enforcement, as environment variable injection alone is insufficient.

References

Community reviews

Loading reviews…