Skip to main content
VulnerabilityPublished Updated

CVE-2026-7259: php_mb_check_encoding() · NULL Pointer Dereference

Affects phpSource GCVE Database

0
Authoritative record:CVE-2026-7259· Low 2.1

Not known to be exploited · CVSS 2.1 Low · fixed in 8.5.6 : update php when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.6, 8.4.21, 8.3.31 +1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L/AU:Y/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade php to 8.5.6, 8.4.21, 8.3.31 or 8.2.31.

Affected software

ProductAffectedFixed in
Bitnamiphppkg:bitnami/phpOther threatsAffected
  • >=8.2.0 <8.2.31
  • >=8.3.0 <8.3.31
  • >=8.4.0 <8.4.21
  • >=8.5.0 <8.5.6
Fixed in
  • 8.2.31
  • 8.3.31
  • 8.4.21
  • 8.5.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade to PHP versions 8.2.31 or later, 8.3.31 or later, 8.4.21 or later, or 8.5.6 or later to remediate the issue. No additional mitigation steps are indicated.

Description

In PHP versions 8.2.* before 8.2.31, 8.3.* before 8.3.31, 8.4.* before 8.4.21, and 8.5.* before 8.5.6, a mismatch between encoding lists in Oniguruma and mbfl leads to  a NULL pointer dereference, resulting in a segmentation fault and denial of service. The vulnerability is exploitable when user-controlled input can influence the encoding passed to mb_regex_encoding().

References

Community reviews

Loading reviews…