CVE-2025-23282: Nvidia graphics drivers 304 · NVIDIA Display Driver for Linux contains a vulnerability where an
Affects nvidia-graphics-drivers-304Source GCVE Database
Not known to be exploited · CVSS 7.0 High · fixed in 535.274.02-0ubuntu0.20.04.1 : patch nvidia-graphics-drivers-304 soon.
Data as of 6 Nov 2026, 05:48 UTC
- Patch
- Available – fixed in 535.274.02-0ubuntu0.20.04.1, 570.195.03-0ubuntu0.20.04.1, 570.195.03-0ubuntu0.20.04.2 +11
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10nvidia-graphics-drivers-570pkg:deb/ubuntu/nvidia-graphics-drivers-570?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.10nvidia-graphics-drivers-570-serverpkg:deb/ubuntu/nvidia-graphics-drivers-570-server?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSnvidia-graphics-drivers-535-serverpkg:deb/ubuntu/nvidia-graphics-drivers-535-server?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSnvidia-graphics-drivers-550pkg:deb/ubuntu/nvidia-graphics-drivers-550?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSnvidia-graphics-drivers-550-serverpkg:deb/ubuntu/nvidia-graphics-drivers-550-server?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSnvidia-graphics-drivers-560pkg:deb/ubuntu/nvidia-graphics-drivers-560?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should upgrade to the fixed versions listed, including 535.274.02-0ubuntu0.20.04.1, 570.195.03-0ubuntu0.20.04.1, 570.195.03-0ubuntu0.20.04.2, 535.274.02-0ubuntu0.22.04.1, and later fixed releases for other Ubuntu versions. Applying these updates will remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
NVIDIA Display Driver for Linux versions prior to certain fixed releases contain a race condition vulnerability that could allow an attacker with limited privileges to escalate their privileges. Exploiting this flaw may lead to code execution, data tampering, denial of service, and information disclosure. The vulnerability has a high severity rating with a CVSS score of 7. Fixed versions addressing this issue have been released.