CVE-2025-23244: Nvidia graphics drivers 304 · NVIDIA GPU Display Driver for Linux contains a vulnerability which could
Affects nvidia-graphics-drivers-304Source GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 535.247.01-0ubuntu0.20.04.1 : patch nvidia-graphics-drivers-304 soon.
Data as of 6 Nov 2026, 05:49 UTC
- Patch
- Available – fixed in 535.247.01-0ubuntu0.20.04.1, 550.163.01-0ubuntu0.20.04.1, 570.133.07-0ubuntu0.20.04.1 +12
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSnvidia-graphics-drivers-550pkg:deb/ubuntu/nvidia-graphics-drivers-550?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSnvidia-graphics-drivers-560pkg:deb/ubuntu/nvidia-graphics-drivers-560?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10nvidia-graphics-drivers-535-serverpkg:deb/ubuntu/nvidia-graphics-drivers-535-server?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10nvidia-graphics-drivers-550pkg:deb/ubuntu/nvidia-graphics-drivers-550?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 25.10nvidia-graphics-drivers-550-serverpkg:deb/ubuntu/nvidia-graphics-drivers-550-server?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 25.10nvidia-graphics-drivers-560pkg:deb/ubuntu/nvidia-graphics-drivers-560?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Fixed versions of the NVIDIA GPU Display Driver for Linux are available for affected Ubuntu releases. Users should upgrade to the fixed versions listed (e.g., 535.247.01-0ubuntu0.20.04.1 and later) to remediate this vulnerability. No additional mitigation steps are indicated beyond applying these official patches.
Description
A vulnerability in the NVIDIA GPU Display Driver for Linux (version 304 and others) allows an unprivileged attacker to escalate permissions. Exploitation could lead to code execution, denial of service, privilege escalation, information disclosure, and data tampering. The issue affects multiple Ubuntu-specific driver versions and has been assigned CVE-2025-23244 with a high severity rating. Fixed versions are available for affected Ubuntu releases.