confluence-markdown-exporter · OAuthLib: Token grants can use attacker-supplied client_id for authorization after authenticating a different client
Affects confluence-markdown-exporterSource GCVE Database
Not known to be exploited · CVSS 8.4 High : upgrade to 5.5.0 soon.
Data as of 31 Oct 2026, 16:06 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 8.4 |
|---|
- Patch
- Available – fixed in 5.5.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade confluence-markdown-exporter to 5.5.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewconfluence-markdown-exporterpkg:brew/confluence-markdown-exporterOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in OAuthlib version 5.5.0 that fixes this vulnerability. Users should upgrade to version 5.5.0 or later. If upgrading is not immediately possible, ensure that application validators do not rely solely on the client_id argument passed by OAuthlib for authorization, but instead authorize strictly based on the authenticated client object (request.client).
Description
OAuthlib contains a vulnerability in its token grant handlers where an authenticated low-privilege client can supply a different client_id in the token request body, causing grant and scope validation to be performed under that other client identity. This affects the client_credentials and password grant flows. The flaw allows a low-privilege client to obtain tokens with scopes or grant types assigned to a higher-privilege client if the application validator authorizes based on the attacker-supplied client_id argument. The issue is fixed in OAuthlib version 5.5.0.
References
- github.com/oauthlib/oauthlib/security/advisories/GHSA-7984-qgvg-3j9c (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-118669 (opens in a new tab)
- github.com/oauthlib/oauthlib/pull/920 (opens in a new tab)
- github.com/oauthlib/oauthlib/commit/c951a1d09f99f14e3240973fa83c4f4287d4753d (opens in a new tab)
- github.com/oauthlib/oauthlib (opens in a new tab)
- github.com/oauthlib/oauthlib/releases/tag/v4.0.0 (opens in a new tab)