Skip to main content
CVE-2026-118669VulnerabilityPublished

twarc · OAuthLib: Token grants can use attacker-supplied client_id for authorization after authenticating a different client

Affects twarcSource GCVE Database

0
Compare
Authoritative record:CVE-2026-118669· High 8.4

Not known to be exploited · CVSS 8.4 High : upgrade to 2.14.1_5 or 1.1.3 soon.

Data as of 31 Oct 2026, 16:22 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.08.4
Patch
Available – fixed in 2.14.1_5, 1.1.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade twarc to 2.14.1_5 or 1.1.3.

Affected software

ProductAffectedFixed in
Homebrewtwarcpkg:brew/twarcOther threatsAffected
  • >=0.8.2 <1.1.3
  • >=1.8.5 <2.14.1_5
Fixed in
  • 1.1.3
  • 2.14.1_5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and fixed versions are 1.1.3 and 2.14.1_5. Users should upgrade to these or later versions to remediate the vulnerability. No other mitigation is required if the application uses the fixed OAuthlib versions. If upgrading is not immediately possible, ensure that the application validator does not authorize based on the client_id argument passed by OAuthlib but instead uses the authenticated client object (request.client) consistently.

Description

OAuthlib contains a vulnerability in its token grant handlers where an authenticated client can supply a different client_id in the token request body, causing grant and scope validation to be performed under that other client identity. This affects the client_credentials and Resource Owner Password Credentials grant flows. The flaw allows a lower-privilege client to obtain tokens with scopes or grant types assigned to a higher-privilege client if the application validator authorizes based on the attacker-supplied client_id argument. The issue is fixed in OAuthlib versions 1.1.3 and 2.14.1_5.

References

Community reviews

Loading reviews…