Skip to main content
CVE-2026-116486VulnerabilityPublished Updated

Objenesis before 3.6 contains a type confusion vulnerability that allows code in one class loader to substitute

Affects objenesisSource GCVE Database

0
Authoritative record:CVE-2026-116486· Low 2.0

Not known to be exploited · CVSS 2.0 Low : update objenesis when convenient.

Data as of 28 Oct 2026, 22:42 UTC

CVSS 4.0 base score
2.0Low
How severe the flaw is on the 0–10 CVSS scale.
CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10objenesispkg:deb/ubuntu/objenesis?arch=source&distro=stonkingOther threatsAffected
  • =3.5-1
Fixed in–
Ubuntu 26.04 LTSobjenesispkg:deb/ubuntu/objenesis?arch=source&distro=resoluteOther threatsAffected
  • =3.4-2
  • =3.4-2build1
  • =3.5-1
Fixed in–
Ubuntu 24.04 LTSobjenesispkg:deb/ubuntu/objenesis?arch=source&distro=nobleOther threatsAffected
  • =3.3-3
Fixed in–
Ubuntu 22.04 LTSobjenesispkg:deb/ubuntu/objenesis?arch=source&distro=jammyOther threatsAffected
  • =3.1-1
  • =3.2-1
Fixed in–
Ubuntu 20.04 LTSobjenesispkg:deb/ubuntu/objenesis?arch=source&distro=focalOther threatsAffected
  • =3.0.1-2
  • =3.1-1
Fixed in–
Ubuntu 18.04 LTSobjenesispkg:deb/ubuntu/objenesis?arch=source&distro=bionicOther threatsAffected
  • =2.6-1
  • =3.0.1-2~18.04
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade to Objenesis version 3.6 or later. Refer to the Debian security tracker advisory for patch details: https://security-tracker.debian.org/tracker/cve-2026-116486.

Description

Objenesis versions before 3.6 have a type confusion vulnerability due to instantiator caching keyed on class name, which can cause objects from one class loader to be substituted into another. This leads to ClassCastException failures when newInstance() returns objects of the wrong class.

References

Community reviews

Loading reviews…