CVE-2026-41083: Ocaml · Multiple issues in command quoting on Windows
Affects ocamlSource GCVE Database
Public exploit available · CVSS 8.6 High : upgrade to 5.5.2 or 4.14.5 as a priority.
Data as of 6 Nov 2026, 15:37 UTC
- Patch
- Available – fixed in 5.5.2, 4.14.5
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 23 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade ocaml to 5.5.2 or 4.14.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
opamocamlpkg:opam/ocamlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in OCaml versions 4.14.5 and 5.5.2 and later. Users should upgrade to these fixed versions to mitigate the vulnerability. The fix includes improved argument quoting in Filename.quote_command and rejection of unsafe arguments in Unix.create_process* by raising exceptions. If upgrading is not immediately possible, avoid passing user-supplied arguments containing metacharacters such as "| & , ; < = > ^ %" to .bat or .cmd scripts via these functions. Consider using Unix.system instead if such characters must be passed.
Description
Multiple command quoting issues were identified in OCaml on Windows platforms affecting the Filename.quote_command and Unix.create_process* functions. These issues could allow unsafe argument quoting or injection when invoking .bat or .cmd scripts with certain metacharacters. The vulnerability affects various OCaml versions prior to 4.14.5 and between 5.0.0 and 5.5.1, as well as specific 3.x releases. A fix has been merged that improves argument quoting and rejects unsafe arguments by raising an exception.