Skip to main content
CVE-2026-123539VulnerabilityPublished

OpenAM before 16.1.4 contains a stored cross-site scripting vulnerability that allows privileged attackers to inject

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123539· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium : upgrade to 16.1.4 when convenient.

Data as of 8 Nov 2026, 06:48 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.04.8
CNA (VulnCheck)CVSS 3.14.8
Patch
Available – fixed in 16.1.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade OpenAM to 16.1.4.

Affected software

ProductAffectedFixed in
OpenIdentityPlatformOpenAMAffected
  • <16.1.4
Fixed in
  • 16.1.4
MavenOpenAMpkg:maven/OpenAMOther threatsAffected
  • <16.1.4
Fixed in
  • 16.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 16.1.4 or later is implied but not explicitly stated in the input data. Until a fix is confirmed, restrict privileges to trusted users only and avoid exposing the OAuth consent page to untrusted users. Validate and encode user input, especially display names, to prevent script injection.

Description

OpenAM versions before 16.1.4 have a stored cross-site scripting (XSS) vulnerability that allows privileged attackers to inject malicious scripts via a user's display name. When a victim views the OAuth 2.0 / OpenID Connect consent page, the injected script executes and can steal the victim's OpenAM session cookie, enabling user impersonation.

References

Community reviews

Loading reviews…