CVE-2026-62191: OpenClaw versions before 2026.6.9 contain an authorization bypass vulnerability in message mutation
Affects openclawSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 2026.6.9 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.6.9
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 14 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade openclaw/openclaw to 2026.6.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubopenclaw/openclawpkg:github/openclaw/openclawOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, review and restrict access to the affected feature and ensure input paths are properly configured to prevent unauthorized access.
Description
OpenClaw versions before 2026.6.9 contain an authorization bypass vulnerability in message mutation handling. This flaw allows lower-trust callers to perform actions that normally require stronger authorization checks. Exploitation is possible when the affected feature is enabled and reachable, and attackers can leverage misconfigured input paths to skip requester authorization and execute privileged operations.