OpenEMR before 8.3.0 contains an SQL injection vulnerability in the Standard REST API patient insurance and employer
Source GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 8.3.0 soon.
Data as of 8 Nov 2026, 17:51 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.1 |
- Patch
- Available – fixed in 8.3.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.
What to do
Upgrade openemr and openemr/openemr to 8.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| openemropenemr | Affected
| Fixed in
|
GitHubopenemr/openemrpkg:github/openemr/openemrOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 8.3.0 of OpenEMR is available that addresses this SQL injection vulnerability. Users should upgrade to version 8.3.0 or later to remediate this issue. Since this is not a cloud service, remediation depends on applying the patch. No other mitigation or temporary workaround is indicated in the provided data.
Description
OpenEMR versions prior to 8.3.0 have an SQL injection vulnerability in the Standard REST API endpoints for patient insurance and employer search. This flaw allows authenticated users, including those with low-privilege patient-portal OAuth2 tokens, to craft parameter names that are concatenated into SQL queries without proper escaping. Exploitation can lead to unauthorized extraction of patient protected health information (PHI), user records, and API client secrets.
References
- github.com/openemr/openemr/security/advisories/GHSA-fhc4-8f9p-8mcc (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-124468 (opens in a new tab)
- github.com/openemr/openemr/commit/e51b0ff9e5b62d43d499d0cd0425290c29ed1212 (opens in a new tab)
- vulncheck.com/advisories/openemr-before-8.3.0-sql-injection-via-patient-insurance-and-employer-rest-api (opens in a new tab)