Skip to main content
CVE-2026-124466VulnerabilityPublished

OpenEMR before 8.4.0 contains a server-side request forgery vulnerability that allows unauthenticated attackers to

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-124466· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 8.4.0 when convenient.

Data as of 8 Nov 2026, 17:51 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.17.2
Patch
Available – fixed in 8.4.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade openemr and openemr/openemr to 8.4.0.

Affected software

ProductAffectedFixed in
openemropenemrAffected
  • <8.4.0
Fixed in
  • 8.4.0
GitHubopenemr/openemrpkg:github/openemr/openemrOther threatsAffected
  • <8.4.0
Fixed in
  • 8.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OpenEMR version 8.4.0 and later. Users should upgrade to version 8.4.0 or above to remediate this vulnerability. Since this is not a cloud service, remediation depends on applying the official patch. No alternative mitigations are provided in the available data.

Description

OpenEMR versions prior to 8.4.0 have a server-side request forgery (SSRF) vulnerability. This flaw allows unauthenticated attackers to register an OAuth2 client with an unvalidated jwks_uri, enabling the server to send arbitrary HTTP requests. Attackers can exploit this via the token introspection endpoint using an unsigned client_assertion to probe internal services and access cloud metadata endpoints.

References

Community reviews

Loading reviews…