CVE-2026-59183: OpenEXR security update
Affects OpenEXRSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 5.5 Medium : upgrade to 3.1.11-10.oe2403sp3 when convenient.
Data as of 4 Nov 2026, 17:00 UTC
- Patch
- Available – fixed in 3.1.11-10.oe2403sp3
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade OpenEXR to 3.1.11-10.oe2403sp3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP3OpenEXRpkg:rpm/openEuler/OpenEXR&distro=openEuler-24.03-LTS-SP3Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security fix is available. Users and organizations should upgrade OpenEXR to versions 3.2.11, 3.3.13, or 3.4.14 to address these vulnerabilities. No additional mitigations are specified by the vendor advisory. Applying the official patches fully mitigates the described issues.
Description
Multiple vulnerabilities in OpenEXR versions before 3.2.11, 3.3.0 through 3.3.12, and 3.4.0 through 3.4.13 allow crafted EXR files to cause memory corruption issues including integer overflow, out-of-bounds reads and writes, use-after-free, and crashes. These issues affect the decoding and processing of deep tiled EXR files and arise from improper handling of dataWindow origins and buffer size calculations. The vulnerabilities are fixed in versions 3.2.11, 3.3.13, and 3.4.14.
References
- openeuler.org/zh/security/security-bulletins/detail/?id=openEuler-SA-2026-4684 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59183 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59184 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59186 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59189 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59981 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59982 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59983 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-61555 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-68515 (opens in a new tab)