OpenPanel before 3.0.0 contains an improper escaping vulnerability in sankey.service.ts that allows authenticated
Affects openpanelSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.0.0 when convenient.
Data as of 27 Oct 2026, 01:59 UTC
- Patch
- Available – fixed in 3.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade openpanel-dev/openpanel to 3.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubopenpanel-dev/openpanelpkg:github/openpanel-dev/openpanelOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Since the vulnerability requires authenticated access, restricting project membership and monitoring for unusual event name inputs may reduce risk.
Description
OpenPanel versions prior to 3.0.0 have an improper escaping vulnerability in the sankey.service.ts component. Authenticated project members can supply backslashes in event names to break ClickHouse string literals. This causes parse errors in the chart.sankey procedure, disabling the Sankey chart endpoint for the project.