Skip to main content
CVE-2026-33453VulnerabilityPublished Updated

Org.apache.camel:camel coap: Apache camel-coap allows header injection that can lead to remote code execution

Affects org.apache.camel:camel-coapSource GCVE Database

0
Authoritative record:CVE-2026-33453· Critical 10.0

Not known to be exploited · public detection template (Nuclei) · CVSS 10.0 Critical : upgrade to 4.14.6 as a priority.

Data as of 27 Oct 2026, 01:40 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.14.6, 4.18.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.apache.camel:camel-coap to 4.14.6; org.apache.camel:camel-coap to 4.18.1.

Affected software

ProductAffectedFixed in
Mavenorg.apache.camel:camel-coapAffected
  • >=4.14.0 <4.14.6
Fixed in
  • 4.14.6
Mavenorg.apache.camel:camel-coapAffected
  • >=4.18.0 <4.18.1
Fixed in
  • 4.18.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected Apache Camel camel-coap component versions to 4.14.6, 4.18.1, or later (including 4.19.0) where the vulnerability is fixed. No other mitigations are specified or recommended by the vendor advisory. Applying the official fix fully resolves the issue.

Description

Apache Camel's camel-coap component versions 4.14.0 through 4.14.5 and 4.18.0 before 4.18.1 are vulnerable to header injection. This occurs because CoAP request URI query parameters are mapped directly into Camel message headers without filtering. An unauthenticated attacker can exploit this to inject arbitrary internal headers, potentially leading to remote code execution when the exchange is forwarded to a header-sensitive downstream producer such as camel-exec. The vulnerability is fixed in versions 4.14.6, 4.18.1, and 4.19.0.

References

Community reviews

Loading reviews…