Skip to main content
CVE-2025-62228VulnerabilityPublished Updated

Org.apache.flink:flink cdc pipeline connectors: Apache Flink CDC is vulnerable to SQL Injection through maliciously

Affects org.apache.flink:flink-cdc-pipeline-connectorsSource GCVE Database

0
Compare
Authoritative record:CVE-2025-62228· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium : upgrade to 3.5.0 when convenient.

Data as of 4 Nov 2026, 18:18 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.5.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/R:U/V:C/RE:L/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.flink:flink-cdc-pipeline-connectors and org.apache.flink:flink-connector-oracle-cdc and org.apache.flink:flink-connector-db2-cdc and org.apache.flink:flink-connector-sqlserver-cdc and org.apache.flink:flink-connector-mysql-cdc to 3.5.0.

Affected software

ProductAffectedFixed in
Mavenorg.apache.flink:flink-cdc-pipeline-connectorsAffected
  • >=3.0.0 <3.5.0
Fixed in
  • 3.5.0
Mavenorg.apache.flink:flink-connector-oracle-cdcAffected
  • >=3.0.0 <3.5.0
Fixed in
  • 3.5.0
Mavenorg.apache.flink:flink-connector-db2-cdcAffected
  • >=3.0.0 <3.5.0
Fixed in
  • 3.5.0
Mavenorg.apache.flink:flink-connector-sqlserver-cdcAffected
  • >=3.0.0 <3.5.0
Fixed in
  • 3.5.0
Mavenorg.apache.flink:flink-connector-mysql-cdcAffected
  • >=3.0.0 <3.5.0
Fixed in
  • 3.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should update Apache Flink CDC to version 3.5.0 or later, where this SQL injection vulnerability is fixed. Since a patch is available and the issue is resolved in 3.5.0, applying this update is the recommended remediation.

Description

Apache Flink CDC versions 3.0.0 through 3.4.x are vulnerable to SQL injection via maliciously crafted identifiers such as database or table names. This vulnerability requires the attacker to have logged-in database user privileges to trigger the issue. The vulnerability is addressed in version 3.5.0.

References

Community reviews

Loading reviews…