Skip to main content
VulnerabilityPublished Updated

CVE-2026-57915: Org.apache.kerby:kerb server: Apache Kerby has a bypass the Kerberos pre-authentication check

Affects org.apache.kerby:kerb-serverSource GCVE Database

0
Compare
Authoritative record:CVE-2026-57915· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade to 2.1.2 soon.

Data as of 3 Nov 2026, 23:28 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.1.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade org.apache.kerby:kerb-server to 2.1.2.

Affected software

ProductAffectedFixed in
Mavenorg.apache.kerby:kerb-serverAffected
  • <2.1.2
Fixed in
  • 2.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

It is possible to bypass the Kerberos pre-authentication check in Apache Kerby by sending a PA-DATA with an unrecognized or unsupported type. Users are recommended to upgrade to version 2.1.2, which fixes this issue.

References

Community reviews

Loading reviews…