Skip to main content
VulnerabilityPublished Updated

CVE-2026-57914: Org.apache.kerby:kerby asn1: Apache Kerby vulnerable to denial of service

Affects org.apache.kerby:kerby-asn1Source GCVE Database

0
Compare
Authoritative record:CVE-2026-57914· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.1.2 when convenient.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.1.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade org.apache.kerby:kerby-asn1 to 2.1.2.

Affected software

ProductAffectedFixed in
Mavenorg.apache.kerby:kerby-asn1Affected
  • <2.1.2
Fixed in
  • 2.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

By sending a deeply nested ASN1 structure to a Apache Kerby client or service, it's possible to trigger a StackOverFlow Exception which can lead to denial of service issues. Users are recommended to upgrade to version 2.1.2, which fixes this issue.

References

Community reviews

Loading reviews…