Org.apache.syncope.core:syncope core spring: Apache Syncope allows malicious administrators to inject Groovy code
Affects org.apache.syncope.core:syncope-core-springSource GCVE Database
Not known to be exploited · CVSS 7.2 High : upgrade to 3.0.14 soon.
Data as of 4 Nov 2026, 18:18 UTC
- Patch
- Available – fixed in 3.0.14, 4.0.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.apache.syncope.core:syncope-core-spring to 3.0.14; org.apache.syncope.core:syncope-core-spring to 4.0.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.syncope.core:syncope-core-spring | Affected
| Fixed in
|
| Mavenorg.apache.syncope.core:syncope-core-spring | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Syncope Core to version 3.0.14 or 4.0.2, where the vulnerability is fixed by sandboxing Groovy code execution. Since an official fix is available, applying these updates is the recommended remediation.
Description
Apache Syncope Core versions prior to 3.0.14 and between 4.0.0-M0 and before 4.0.2 allow malicious administrators to inject Groovy code that can be executed remotely. This vulnerability arises from the feature that allows runtime reload of custom Groovy implementations, which was not properly sandboxed. The issue is fixed in versions 3.0.14 and 4.0.2 by enforcing sandboxing of Groovy code execution.
References
- nvd.nist.gov/vuln/detail/CVE-2025-57738 (opens in a new tab)
- github.com/apache/syncope/commit/88c2b5b0be9e2ed66007d672e786165bc266e717 (opens in a new tab)
- github.com/apache/syncope/commit/8b08c4d5785599a0e38830dcff89738b93f02a16 (opens in a new tab)
- issues.apache.org/jira/browse/SYNCOPE-1907 (opens in a new tab)
- lists.apache.org/thread/x7cv6xv7z76y49grdr1hgj1pzw5zbby6 (opens in a new tab)
- syncope.apache.org/security (opens in a new tab)
- github.com/apache/syncope (opens in a new tab)
- openwall.com/lists/oss-security/2025/10/20/1 (opens in a new tab)