CVE-2024-34750: Org.apache.tomcat.embed:tomcat embed core: Apache Tomcat - Denial of Service
Affects org.apache.tomcat.embed:tomcat-embed-coreSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 11.0.0-M21 soon.
Data as of 30 Oct 2026, 00:38 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 11.0.0-M21, 10.1.25, 9.0.90
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat-coyote to 11.0.0-M21; org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat-coyote to 10.1.25; org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat-coyote to 9.0.90.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.tomcat.embed:tomcat-embed-core | Affected
| Fixed in
|
| Mavenorg.apache.tomcat.embed:tomcat-embed-core | Affected
| Fixed in
|
| Mavenorg.apache.tomcat.embed:tomcat-embed-core | Affected
| Fixed in
|
| Mavenorg.apache.tomcat:tomcat-coyote | Affected
| Fixed in
|
| Mavenorg.apache.tomcat:tomcat-coyote | Affected
| Fixed in
|
| Mavenorg.apache.tomcat:tomcat-coyote | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users are strongly advised to upgrade to Apache Tomcat versions 11.0.0-M21, 10.1.25, or 9.0.90, which contain the fix for this vulnerability. Applying these updates will prevent exploitation of the issue.
Description
Apache Tomcat versions prior to 11.0.0-M21, 10.1.25, and 9.0.90 contain a vulnerability in HTTP/2 stream processing where excessive HTTP headers are improperly handled. This causes miscounting of active HTTP/2 streams and results in an infinite timeout, allowing connections to remain open indefinitely. This can lead to denial of service by exhausting server resources. Users should upgrade to the fixed versions to resolve this issue.
References
- nvd.nist.gov/vuln/detail/CVE-2024-34750 (opens in a new tab)
- github.com/apache/tomcat/commit/2344a4c0d03e307ba6b8ab6dc8b894cc8bac63f2 (opens in a new tab)
- github.com/apache/tomcat/commit/2afae300c9ac9c0e516e2e9de580847d925365c3 (opens in a new tab)
- github.com/apache/tomcat/commit/9fec9a82887853402833a80b584e3762c7423f5f (opens in a new tab)
- github.com/apache/tomcat (opens in a new tab)
- lists.apache.org/thread/4kqf0bc9gxymjc2x7v3p7dvplnl77y8l (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/07/msg00009.html (opens in a new tab)
- security.netapp.com/advisory/ntap-20240816-0004 (opens in a new tab)
- tomcat.apache.org/security-10.html (opens in a new tab)
- tomcat.apache.org/security-11.html (opens in a new tab)
- tomcat.apache.org/security-9.html (opens in a new tab)