Skip to main content
CVE-2024-50379VulnerabilityPublished Updated

Org.apache.tomcat:tomcat catalina: Apache Tomcat Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability

Affects org.apache.tomcat:tomcat-catalinaSource GCVE Database

0
Compare
Authoritative record:CVE-2024-50379· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 11.0.2 as a priority.

Data as of 30 Oct 2026, 00:43 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.19.8
Patch
Available – fixed in 11.0.2, 10.1.34, 9.0.98
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 11.0.2; org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 10.1.34; org.apache.tomcat:tomcat-catalina and org.apache.tomcat.embed:tomcat-embed-core to 9.0.98.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=11.0.0-M1 <11.0.2
Fixed in
  • 11.0.2
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=10.1.0-M1 <10.1.34
Fixed in
  • 10.1.34
Mavenorg.apache.tomcat:tomcat-catalinaAffected
  • >=9.0.0.M1 <9.0.98
Fixed in
  • 9.0.98
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=11.0.0-M1 <11.0.2
Fixed in
  • 11.0.2
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=10.1.0-M1 <10.1.34
Fixed in
  • 10.1.34
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=9.0.0.M1 <9.0.98
Fixed in
  • 9.0.98

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat installations to versions 11.0.2, 10.1.34, or 9.0.98 or later, where the vulnerability is fixed. Since the vulnerability requires the default servlet to be enabled for write access (a non-default configuration), ensuring this setting is not enabled can reduce exposure. No other mitigations are specified by the vendor.

Description

A Time-of-check Time-of-use (TOCTOU) race condition vulnerability exists in Apache Tomcat during JSP compilation. This flaw permits remote code execution (RCE) on case-insensitive file systems when the default servlet is enabled for write access, which is a non-default configuration. The vulnerability affects multiple versions across Apache Tomcat 8.5, 9.0, 10.1, and 11.0 branches. Fixed versions are available and users are advised to upgrade to these to mitigate the risk.

References

Community reviews

Loading reviews…