Skip to main content
CVE-2024-41169VulnerabilityPublished Updated

Org.apache.zeppelin:zeppelin interpreter: Apache Zeppelin exposes server resources to unauthenticated attackers

Affects org.apache.zeppelin:zeppelin-interpreterSource GCVE Database

0
Compare
Authoritative record:CVE-2024-41169· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 0.12.0 soon.

Data as of 4 Nov 2026, 18:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
Patch
Available – fixed in 0.12.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.zeppelin:zeppelin-interpreter and org.apache.zeppelin:zeppelin-server to 0.12.0.

Affected software

ProductAffectedFixed in
Mavenorg.apache.zeppelin:zeppelin-interpreterAffected
  • >=0.10.1 <0.12.0
Fixed in
  • 0.12.0
Mavenorg.apache.zeppelin:zeppelin-serverAffected
  • >=0.10.1 <0.12.0
Fixed in
  • 0.12.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Zeppelin to version 0.12.0 or later, where the vulnerability is fixed by removing the Cluster Interpreter. This is the official and complete remediation for this issue.

Description

Apache Zeppelin versions from 0.10.1 up to but not including 0.12.0 contain a vulnerability in the raft server protocol that allows unauthenticated attackers to access server resources such as directories and files. This issue is fixed in version 0.12.0 by removing the Cluster Interpreter component.

References

Community reviews

Loading reviews…