Org.jenkins ci.plugins:credentials binding: Jenkins Credentials Binding Plugin vulnerability can expose sensitive
Affects org.jenkins-ci.plugins:credentials-bindingSource GCVE Database
Not known to be exploited · CVSS 7.3 High : upgrade to 687.689.v1a soon.
Data as of 4 Nov 2026, 18:13 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.3 |
|---|
- Patch
- Available – fixed in 687.689.v1a
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 9 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.jenkins-ci.plugins:credentials-binding to 687.689.v1a.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.jenkins-ci.plugins:credentials-binding | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the Jenkins Credentials Binding Plugin to version 687.689.v1a or later, where the vulnerability is fixed by proper masking of credentials in exception error messages. No other mitigation is required as the patch fully addresses the issue.
Description
A vulnerability in Jenkins Credentials Binding Plugin versions 687.v619cb_15e923f and earlier allows sensitive credentials to be exposed in build logs because the plugin does not properly mask credentials in exception error messages. This issue is fixed in version 687.689.v1a, which masks credentials in error messages by rethrowing exceptions with masked content.