Skip to main content
VulnerabilityPublished

CVE-2026-9800: Org.keycloak:keycloak services: Keycloak vulnerable to authorization bypass via incorrect uri comparison

Affects org.keycloak:keycloak-servicesSource GCVE Database

0
Compare
Authoritative record:CVE-2026-9800· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 26.6.4 soon.

Data as of 29 Oct 2026, 18:38 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.6.4, 26.0.10
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade org.keycloak:keycloak-services to 26.6.4; org.keycloak:keycloak-policy-enforcer to 26.0.10.

Affected software

ProductAffectedFixed in
Mavenorg.keycloak:keycloak-servicesAffected
  • <26.6.4
Fixed in
  • 26.6.4
Mavenorg.keycloak:keycloak-policy-enforcerAffected
  • <26.0.10
Fixed in
  • 26.0.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading to Keycloak versions 26.6.4 or 26.0.10 or later. Red Hat has released security advisories and updated packages to address this issue. Users should back up their existing installations before applying updates. No additional mitigations are indicated beyond applying the official fix.

Description

A vulnerability in Keycloak Policy Enforcer allows any authenticated user to bypass all authorization policies, including role, scope, and UMA permission checks. This occurs when an attacker includes the configured access-denied page path within a request URL, either as a path segment or a query parameter, enabling unauthorized access to protected resources. The flaw affects Keycloak versions prior to 26.6.4 and 26.0.10. A fix is available in these versions.

References

Community reviews

Loading reviews…