Org.xwiki.platform:xwiki platform webjars api: XWiki configuration files can be accessed through the webjars API
Affects org.xwiki.platform:xwiki-platform-webjars-apiSource GCVE Database
Not known to be exploited · public detection template (Nuclei) · CVSS 9.3 Critical : upgrade to 16.10.7 as a priority.
Data as of 27 Oct 2026, 01:29 UTC
- Patch
- Available – fixed in 16.10.7, 17.4.0-rc-1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Sep 2025
Detectable: evidence found.
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.xwiki.platform:xwiki-platform-webjars-api to 16.10.7; org.xwiki.platform:xwiki-platform-webjars-api to 17.4.0-rc-1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.xwiki.platform:xwiki-platform-webjars-api | Affected
| Fixed in
|
| Mavenorg.xwiki.platform:xwiki-platform-webjars-api | Affected
| Fixed in
|
| Mavenorg.xwiki.platform:xwiki-platform-webjars | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected XWiki platform webjars API versions to 16.10.7 or 17.4.0-rc-1 or later, where the vulnerability is patched. There are no known workarounds; therefore, applying the official fix is the only effective mitigation.
Description
A directory traversal vulnerability in the XWiki platform webjars API allows unauthorized access to configuration files by exploiting URL encoding and decoding inconsistencies. This can expose sensitive configuration data. The issue affects multiple versions prior to 16.10.7 and 17.4.0-rc-1 and has been patched in those releases. No workaround other than upgrading is available.
References
- github.com/xwiki/xwiki-platform/security/advisories/GHSA-qww7-89xh-x7m7 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-55747 (opens in a new tab)
- github.com/xwiki/xwiki-platform/commit/9e7b4c03f2143978d891109a17159f73d4cdd318 (opens in a new tab)
- github.com/xwiki/xwiki-platform (opens in a new tab)
- jira.xwiki.org/browse/XWIKI-19350 (opens in a new tab)