CVE-2025-61304: Dynatrace ActiveGate ping extension · OS Command Injection Vulnerability
Source GCVE Database
Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.017 as a priority.
Data as of 4 Nov 2026, 18:21 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 9.8 |
|---|
- Patch
- Available – fixed in 1.017
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade pentastic-be/CVE-2025-61304 to 1.017.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubpentastic-be/CVE-2025-61304pkg:github/pentastic-be/CVE-2025-61304Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict access to the vulnerable service and validate inputs where possible to mitigate risk.
Description
An OS command injection vulnerability exists in the Dynatrace ActiveGate ping extension up to version 1.016. This flaw allows an attacker to execute arbitrary operating system commands via a crafted IP address input. The vulnerability has a critical severity with a CVSS score of 9.8, indicating high impact on confidentiality, integrity, and availability.