Skip to main content
VulnerabilityPublished Updated

CVE-2025-12104: Outdated and Vulnerable UI Dependencies might potentially lead to exploitation.This issue affects

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-12104· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 1.19.6 as a priority.

Data as of 4 Nov 2026, 18:50 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.19.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade azure-access-technology/blu-ic2 to 1.19.6.

Affected software

ProductAffectedFixed in
npmazure-access-technology/blu-ic2pkg:npm/azure-access-technology/blu-ic2Other threatsAffected
  • <1.19.6
Fixed in
  • 1.19.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

CVE-2025-12104 is a critical vulnerability involving outdated and vulnerable UI dependencies in BLU-IC2 and BLU-IC4 products up to version 1.19.5. The flaw could potentially be exploited to cause high impact on confidentiality, integrity, and availability.

References

Community reviews

Loading reviews…