Skip to main content
CVE-2026-116801VulnerabilityPublished

Parse Server before 8.6.105 and 9.0.0 before 9.10.5-alpha.6 does not validate the owning object reference in

Source GCVE Database

0
Authoritative record:CVE-2026-116801· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 9.10.5-alpha.6 when convenient.

Data as of 27 Oct 2026, 02:12 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.10.5-alpha.6, 8.6.105
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade parse-server to 9.10.5-alpha.6; parse-server to 8.6.105; parse-server to 9.10.5-alpha.6 or 8.6.105.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.10.5-alpha.6
Fixed in
  • 9.10.5-alpha.6
parse-communityparse-serverAffected
  • <8.6.105
Fixed in
  • 8.6.105
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • >=9.0.0 <9.10.5-alpha.6
  • <8.6.105
Fixed in
  • 9.10.5-alpha.6
  • 8.6.105

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict read access to owning classes to trusted clients only to reduce the risk of information disclosure via this vulnerability.

Description

Parse Server versions before 8.6.105 and 9.0.0 before 9.10.5-alpha.6 contain a vulnerability where the owning object reference in $relatedTo relation queries is not properly validated. This allows a client with read access to at least one object of the owning class to bypass owning-object ACL checks by supplying a query operator instead of an object ID, potentially disclosing which readable objects are linked to owning objects it cannot read.

References

Community reviews

Loading reviews…