Skip to main content
CVE-2026-120310VulnerabilityPublished

Parse Server before 8.6.109 and 9.0.0 before 9.10.6-alpha.1 returns stored field values in object update responses

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-120310· Low 2.3

Not known to be exploited · CVSS 2.3 Low : upgrade to 9.10.6-alpha.1 when convenient.

Data as of 2 Nov 2026, 04:59 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.02.3
CNA (VulnCheck)CVSS 3.13.1
Patch
Available – fixed in 9.10.6-alpha.1, 8.6.109
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade parse-server to 9.10.6-alpha.1; parse-server to 8.6.109; parse-server to 9.10.6-alpha.1 or 8.6.109.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.10.6-alpha.1
Fixed in
  • 9.10.6-alpha.1
parse-communityparse-serverAffected
  • <8.6.109
Fixed in
  • 8.6.109
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • >=9.0.0 <9.10.6-alpha.1
  • <8.6.109
Fixed in
  • 9.10.6-alpha.1
  • 8.6.109

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Parse Server versions 8.6.109 and 9.10.6-alpha.1 and later. Users should upgrade to these versions or newer to resolve the issue. No additional mitigations are indicated by the vendor advisory.

Description

Parse Server versions before 8.6.109 and 9.0.0 before 9.10.6-alpha.1 have a vulnerability where stored field values are returned in object update responses without verifying read access. This allows clients with update permissions but without read permissions to access object data, including atomic operation results and Cloud Code trigger-set values.

References

Community reviews

Loading reviews…