CVE-2026-112769: Parse Server before 8.6.98 and 9.x before 9.10.3 Session Class-Level Permission Bypass
Affects parseSource GCVE Database
Not known to be exploited · CVSS 2.3 Low : upgrade to 9.10.3 or 8.6.98 when convenient.
Data as of 27 Oct 2026, 05:11 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.10.3, 8.6.98
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 19 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade parse to 9.10.3 or 8.6.98.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamiparsepkg:bitnami/parseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Parse Server before 8.6.98 and 9.0.0 before 9.10.3 does not enforce the create and addField class-level permissions of the _Session class when creating sessions. An authenticated user, or anyone holding that user's session token, can send POST requests to /sessions or /classes/_Session to create additional sessions for that user and add fields to _Session; these sessions are not revoked when the original session is logged out.
References
- github.com/parse-community/parse-server/security/advisories/GHSA-gj37-5hg5-p729 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-112769 (opens in a new tab)
- vulncheck.com/advisories/parse-server-before-8.6.98-and-9-x-before-9.10.3-alpha.1-session-class-level-permission-bypass (opens in a new tab)