Skip to main content
CVE-2026-119571VulnerabilityPublished

Parse Server from 9.7.0 before 9.10.5-alpha.10 contains an authorization flaw that applies _Installation updates

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-119571· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium : upgrade to 9.10.5-alpha.10 when convenient.

Data as of 30 Oct 2026, 16:51 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.3
CNA (VulnCheck)CVSS 3.13.7
Patch
Available – fixed in 9.10.5-alpha.10
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.10.5-alpha.10.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.7.0 <9.10.5-alpha.10
Fixed in
  • 9.10.5-alpha.10
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • >=9.7.0 <9.10.5-alpha.10
Fixed in
  • 9.10.5-alpha.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider disabling or carefully managing the protectedFieldsTriggerExempt feature and restrict knowledge of installation object IDs to trusted parties.

Description

Parse Server versions from 9.7.0 up to but not including 9.10.5-alpha.10 have an authorization flaw involving _Installation updates. This flaw allows an attacker who knows another installation's object ID to trigger processing of protected fields in a beforeSave trigger for that installation, even when protectedFieldsTriggerExempt is enabled.

References

Community reviews

Loading reviews…